Register now or log in to join your professional community.
<p>I've a backbone router having two wan connections of different Bandwidths,many other Customer is landing in that particular Backbone router. I need to load balance each of the wan link without any problem to the customer.</p> <p> For eg: One wan link34 mb and other20mb, if one link is having18mb traffic automatically need to through the other wan link how can i do it?</p>
For the load sharing, use the ip cef configuration command along with the ip load-sharing per-packet/per-destination interface submode command.
if you want to limit an interface to18Mb use the rate limite interface command
We can enable traffic engineering between both wan links and define a bandwidth threshold value so as to switch the traffic to explicitly defined path so that it will start sending the packet to the other WAN link to avoid the congestion on IGP preferred path.
Use Microtic system PCC (per Connection Classifier)
yes, cisco CEF which is Layer 3 switching technology used for Load Balancing, there are two main components of CEF operation (Forwarding Information base, and Adjacency Tables)
Use cisco Intilligent WAN for this it will give you lot of option to loadbalance the traffic based on various attributes.
1. availbility
2. Bandwdith Availble
3. Destination etc.
For more information check for Cisco PFR solution in design guide.
Load balancing with two ISP links
interface FastEthernet0
description ISP1
ip nat outside
interface FastEthernet1
description ISP2
ip nat outside
interface Vlan1
ip nat inside
ip nat inside source route-map ISP1 interface FastEthernet0 overload
ip nat inside source route-map ISP2 interface FastEthernet1 overload
access-list110 permit ip192.168.52.00.0.0.255 any
route-map ISP1 permit10
match ip address110
match interface FastEthernet0
!
route-map ISP2 permit10
match ip address110
match interface FastEthernet1
If you want to give priority to any WAN connection for any specific subnet you can use track command
ip nat inside source route-map ISP1 interface FastEthernet0 overload track100
---------------------------------------------------------------------------
Dividing single WAN (ISP) Bandwidth among two subnets. here consider30mb. Subnet52.0 will be using
30% of30Mb which will be9 and subnet192.168.53.0 will be using70% which will be21 mb. incase the assigned
bandwidth is not fully used by any subnet the remaing will be shared with other if other subnet limit reaches maximum
access-list1 permit192.168.52.00.0.0.255
access-list1 permit192.168.53.00.0.0.255
class-map subnet-a
match access-group1
class-map subnet-b
match access-group2
policy-map subnets
class-map subnet-a
bandwidth percent30
class-map subnet-b
bandwidth percent70
policy-map physical
class class-default
police conform-action transmit exceed-action drop
service-policy subnets
exit
int fastethernet4
service-policy output physical
exit
https://supportforums.cisco.com/document/6/load-balancing-using-performance-routing-pfroer