Inscrivez-vous ou connectez-vous pour rejoindre votre communauté professionnelle.
<p>تفعيل DHCP داخل الشبكة بواسطة روترات سيسكو</p>
ROUTER:
conf t
ip dhcp pool xnetwork
network10.0.0.0 255.0.0.0
default-router10.0.0.1
dns-server2.2.2.2 (for example)
exit
! if you want to exclude some ip addresses for dhcp not to leases this ip addresses type this...
ip dhcp excluded-address10.0.0.1 10.0.0.9 (for example)
! now configure the server who ask for an ip address from the router
conf t
interface fa0/0 (for example)
ip address dhcp
no shut
exit
! then in L3SW, configure a DHCP Helper. means, inform the router / l3sw that if it receives a dhcp broadcast request, do not drop the packet, instead, forward te broadcast to a preconfigured ip address of a DHCP SERVER.
! for example from l3sw perspective, ip address of the DHCP SERVER is10.0.0.2
L3SW:
conf t
interface vlan1 (for example)
ip helper-address10.0.0.2
exit
Router
conf t
ip dhcp pool XYZ
network10.0.0.0255.0.0.0
default-network10.0.0.1
end
Layer3 Switch
conf t
interface vlan XYZ
ip dhcp pool XYZ
config)# ip dhcp pool xyz)
config)# network10.0.0.0 255.0.0.0)
config)# default- router10.0.0.1